Table of Contents Network Topology 2



Download 226.03 Kb.
Date01.06.2018
Size226.03 Kb.

Table of Contents


Network Topology 2

Configuring OSPF on the Stoke router 3

Configuring OSPF on the London router 4

Viewing the routing table for the London router 5

Displaying the OSPF neighbours on the London router 5

Displaying the OSPF database on the London router 6

Displaying OSPF on the London router’s serial 0/0/1 interface 6

Displaying the routing table on the Stoke router 7

Configuring OSPF on the Glasgow router 7

Configuring a default static route on London 8

Propagating the default static route on London via OSPF 8

Checking Stoke’s routing table for propagated default static route 9



Checking Glasgow’s routing table for propagated default static route 10







Network Topology


Passwords: c1sco and cla$$


Configuring OSPF on the Stoke router

Stoke Router. Authorised access only!

User Access Verification

Password:

Stoke>enable

Password:

Stoke#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Stoke(config)#router ospf 51

Stoke(config-router)#network 192.168.1.0 0.0.0.127 area 0

Stoke(config-router)#network 145.50.0.0 0.0.255.255 area 0

Stoke(config-router)#network 155.50.0.0 0.0.255.255 area 0

Stoke(config-router)#exit

Stoke(config)#exit

Stoke#


%SYS-5-CONFIG_I: Configured from console by console

Stoke#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

Stoke#

Configuring OSPF on the London router


London Router! Keep out! Authorised access only!

User Access Verification

Password:

London>ena

Password:

London#conf t

Enter configuration commands, one per line. End with CNTL/Z.

London(config)#router ospf 51

London(config-router)#network 192.168.1.192 0.0.0.31 area 0

London(config-router)#network 165.50.0.0 0.0.255.255 area 0

London(config-router)#network 4.0.0.0 0.255.255.255 area 0

London(config-router)#network 155.50.0.0 0.0.255.255 area 0



London(config-router)#

00:19:00: %OSPF-5-ADJCHG: Process 51, Nbr 192.168.1.126 on Serial0/0/0 from LOADING to FULL, Loading Done

London(config-router)#exit

London(config)#exit

London#


%SYS-5-CONFIG_I: Configured from console by console

London#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

Viewing the routing table for the London router


London#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 4.0.0.0/8 is directly connected, GigabitEthernet0/1

L 4.0.0.2/32 is directly connected, GigabitEthernet0/1



O 145.50.0.0/16 [110/128] via 155.50.0.2, 00:00:55, Serial0/0/0

155.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 155.50.0.0/16 is directly connected, Serial0/0/0

L 155.50.0.1/32 is directly connected, Serial0/0/0

165.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 165.50.0.0/16 is directly connected, Serial0/0/1

L 165.50.0.1/32 is directly connected, Serial0/0/1

192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks



O 192.168.1.0/25 [110/65] via 155.50.0.2, 00:00:55, Serial0/0/0

C 192.168.1.192/27 is directly connected, GigabitEthernet0/0

L 192.168.1.222/32 is directly connected, GigabitEthernet0/0

Displaying the OSPF neighbours on the London router


London#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.1.126 0 FULL/ - 00:00:39 155.50.0.2 Serial0/0/0

London#show ip ospf ?



<1-65535> Process ID number

border-routers Border and Boundary Router Information

database Database summary

interface Interface information

neighbor Neighbor list

virtual-links Virtual link information


Displaying the OSPF database on the London router


London#show ip ospf database

OSPF Router with ID (192.168.1.222) (Process ID 51)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count

192.168.1.222 192.168.1.222 137 0x80000005 0x002c24 5

192.168.1.126 192.168.1.126 137 0x80000004 0x002ad0 4


Displaying OSPF on the London router’s serial 0/0/1 interface


London#show ip ospf interface serial 0/0/1

Serial0/0/1 is up, line protocol is up

Internet address is 165.50.0.1/16, Area 0

Process ID 51, Router ID 192.168.1.222, Network Type POINT-TO-POINT, Cost: 64

Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0

No designated router on this network

No backup designated router on this network

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:02

Index 2/2, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 1, maximum is 1

Last flood scan time is 0 msec, maximum is 0 msec

Suppress hello for 0 neighbor(s)




Displaying the routing table on the Stoke router


Stoke#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

O 4.0.0.0/8 [110/65] via 155.50.0.1, 00:03:40, Serial0/0/1

145.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 145.50.0.0/16 is directly connected, Serial0/0/0

L 145.50.0.1/32 is directly connected, Serial0/0/0

155.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 155.50.0.0/16 is directly connected, Serial0/0/1

L 155.50.0.2/32 is directly connected, Serial0/0/1

O 165.50.0.0/16 [110/128] via 155.50.0.1, 00:03:40, Serial0/0/1

192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks

C 192.168.1.0/25 is directly connected, GigabitEthernet0/0

L 192.168.1.126/32 is directly connected, GigabitEthernet0/0



O 192.168.1.192/27 [110/65] via 155.50.0.1, 00:03:40, Serial0/0/1

Stoke#


Configuring OSPF on the Glasgow router

Glasgow router! Authorized access only! Keep out!

User Access Verification

Password:

Glasgow>enable

Password:

Glasgow#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Glasgow(config)#router ospf 51

Glasgow(config-router)#network 192.168.1.128 0.0.0.63 area 0

Glasgow(config-router)#network 165.50.0.0 0.0.255.255 area 0

Glasgow(config-router)#network 145.50.0.0 0.0.255.255 area 0

00:31:33: %OSPF-5-ADJCHG: Process 51, Nbr 192.168.1.222 on Serial0/0/1 from LOADING to FULL, Loading Done

Glasgow(config-router)#



00:31:34: %OSPF-5-ADJCHG: Process 51, Nbr 192.168.1.126 on Serial0/0/0 from LOADING to FULL, Loading Done

Glasgow(config-router)#exit

Glasgow(config)#exit

Glasgow#


Glasgow#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]


Glasgow#

Configuring a default static route on London


London#conf t

Enter configuration commands, one per line. End with CNTL/Z.

London(config)#ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/1

Propagating the default static route on London via OSPF


London(config)#router ospf 51

London(config-router)#default-information originate

London(config-router)#exit

London(config)#exit

London#


London#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]


London#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 4.0.0.0/8 is directly connected, GigabitEthernet0/1

L 4.0.0.2/32 is directly connected, GigabitEthernet0/1

O 145.50.0.0/16 [110/128] via 165.50.0.2, 00:01:38, Serial0/0/1

[110/128] via 155.50.0.2, 00:01:38, Serial0/0/0

155.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 155.50.0.0/16 is directly connected, Serial0/0/0

L 155.50.0.1/32 is directly connected, Serial0/0/0

165.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 165.50.0.0/16 is directly connected, Serial0/0/1

L 165.50.0.1/32 is directly connected, Serial0/0/1

192.168.1.0/24 is variably subnetted, 4 subnets, 4 masks

O 192.168.1.0/25 [110/65] via 155.50.0.2, 00:14:22, Serial0/0/0

O 192.168.1.128/26 [110/65] via 165.50.0.2, 00:01:48, Serial0/0/1

C 192.168.1.192/27 is directly connected, GigabitEthernet0/0

L 192.168.1.222/32 is directly connected, GigabitEthernet0/0

S* 0.0.0.0/0 is directly connected, GigabitEthernet0/1

London#

Checking Stoke’s routing table for propagated default static route


Stoke#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 155.50.0.1 to network 0.0.0.0

O 4.0.0.0/8 [110/65] via 155.50.0.1, 00:14:52, Serial0/0/1

145.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 145.50.0.0/16 is directly connected, Serial0/0/0

L 145.50.0.1/32 is directly connected, Serial0/0/0

155.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 155.50.0.0/16 is directly connected, Serial0/0/1

L 155.50.0.2/32 is directly connected, Serial0/0/1

O 165.50.0.0/16 [110/128] via 145.50.0.2, 00:02:04, Serial0/0/0

[110/128] via 155.50.0.1, 00:02:04, Serial0/0/1

192.168.1.0/24 is variably subnetted, 4 subnets, 4 masks

C 192.168.1.0/25 is directly connected, GigabitEthernet0/0

L 192.168.1.126/32 is directly connected, GigabitEthernet0/0

O 192.168.1.128/26 [110/65] via 145.50.0.2, 00:02:04, Serial0/0/0

O 192.168.1.192/27 [110/65] via 155.50.0.1, 00:14:52, Serial0/0/1

O*E2 0.0.0.0/0 [110/1] via 155.50.0.1, 00:00:34, Serial0/0/1

Stoke#

Checking Glasgow’s routing table for propagated default static route


Glasgow# show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 165.50.0.1 to network 0.0.0.0

O 4.0.0.0/8 [110/65] via 165.50.0.1, 00:02:41, Serial0/0/1

145.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 145.50.0.0/16 is directly connected, Serial0/0/0

L 145.50.0.2/32 is directly connected, Serial0/0/0

O 155.50.0.0/16 [110/128] via 165.50.0.1, 00:02:41, Serial0/0/1

[110/128] via 145.50.0.1, 00:02:41, Serial0/0/0

165.50.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 165.50.0.0/16 is directly connected, Serial0/0/1

L 165.50.0.2/32 is directly connected, Serial0/0/1

192.168.1.0/24 is variably subnetted, 4 subnets, 4 masks

O 192.168.1.0/25 [110/65] via 145.50.0.1, 00:02:41, Serial0/0/0

C 192.168.1.128/26 is directly connected, GigabitEthernet0/0

L 192.168.1.190/32 is directly connected, GigabitEthernet0/0

O 192.168.1.192/27 [110/65] via 165.50.0.1, 00:02:41, Serial0/0/1

O*E2 0.0.0.0/0 [110/1] via 165.50.0.1, 00:01:00, Serial0/0/1

Glasgow#




Configuring OSPF





Download 226.03 Kb.

Share with your friends:




The database is protected by copyright ©ininet.org 2020
send message

    Main page